Install php-soap in CentOS 5.6 with PHP 5.2.17

Sophie Fromage asked:

yum install php-soap

results in “No package php-soap available” warning. Removing “exclude =php*” from /etc/yum.conf results in confirmation to install php-soap & php-common VERSION 5.1.6-39.el5_8.

I’m afraid to install php components with version 5.1.6* in an OS with php 5.2.17. Should I be? Won’t earlier 5.1.6* components cause problems with later 5.2.17 php environment?

My answer:


Go back to wherever you got the php-5.2 packages and find the matching php-soap package.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.