Ubuntu: apt-get -f install lighttpd does not install

user61104 asked:

I’m trying to install lighttpd. When running sudo apt-get -f install , I’m getting this error :

~/dev/downlaod$ sudo apt-get -f install lighttpd
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
  codeblocks-contrib: Depends: libwxsmithlib0 (= 10.05-1) but 10.05svn8059-0ubuntu1~lucid is to be installed
                      Depends: codeblocks-contrib-common (= 10.05-1) but 10.05svn8059-0ubuntu1~lucid is to be installed
                      Depends: codeblocks (= 10.05-1) but 10.05svn8059-0ubuntu1~lucid is to be installed
  codeblocks-contrib-common: Breaks: codeblocks-contrib (< 10.05svn8059-0ubuntu1~lucid) but 10.05-1 is to be installed
  lighttpd: Depends: libterm-readline-perl-perl but it is not going to be installed
            Recommends: spawn-fcgi but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I’m using : Ubuntu 10.04.4 LTS
Is there any way to fix this ?

My answer:


Do what it suggested you do: Try 'apt-get -f install' with no packages.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.