Stuck at low resolution: Monitor as well as display adaptor not recognized in Windows Server 2012

DeepSpace101 asked:

We’re testing an on-premise Windows Server 2012 (Datacenter) server. It has been installed with the GUI because it’s internal, test only – we don’t care about the attack surface until we’re ready.

Problem:
When locally/physically logging into the server (no Remote Desktop etc), the default display resolution is quite poor (4:3 on a 20:9 display). The devices detected are:

  • Monitor:
    • Detected: Generic non-PnP monitor
    • Actual: Asus 24″ monitor
  • Display Adaptor:
    • Detected: Microsoft Basic Display Adaptor
    • Actual: ATI Radeon 5770

The Hyper-V role is also installed and everything under the “User Interfaces and infrastructure” is installed (i.e. Graphical Mgmt Tools and Infrastructure, Desktop experience as well as Server Graphical Shell)

Booting the same machine into Windows 8 yields working and recognized monitor as well as as display adaptor. On a related note, even the sound card is not recognized (HD audio codec by VIA) in Server 2012 while it is (out of the box) in Windows 8. I’m wondering if Windows Server 2012 is itself running on top of the Hyper-V hypervisor (like Xen’s dom0 OS), which is excluding all audio/video devices from being natively recognized. Anyway …

Question:

  • How can I get the display adaptor recognized and working in Server 2012? Without it the entire feature GUI feature is quite an eyesore
  • Given the shared lineage, I assumed the non-Metro GUI experience would be fairly similar to Windows 8. Is that a valid assumption?

My answer:


The Microsoft Basic Display Adapter, as the name implies, is meant to be basic. This means you are locked to a resolution of 1024×768 and have minimal desktop eye candy.

enter image description here

To resolve this issue, install display drivers provided by the video card manufacturer. AMD’s Catalyst 12.8 or later “for Windows 8” has been working perfectly for me on Server 2012.

Or, you can just ignore the issue. If you’re going to install Server Core into production (eventually) anyway, then it doesn’t really matter much whether you have display drivers or not.

(I don’t know about your audio; mine works fine…)


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.