Install gettext-0.17-1.el5.i386.rpm on CentOS 5.8 i386 gives "/usr/bin/python is needed" error

viji asked:

I’ve removed yum by mistake. So, now I’m installing all the dependencies needed by yum manually. One of those is gettext-0.17-1.el5.i386.rpm and when I try to install it gives the following error,

error: Failed dependencies:
    /usr/bin/python is needed by gettext-0.17-1.el5.i386

which is weird since I’ve installed python 2.6 already in the system.

#python -V
Python 2.6.8
#which python
/usr/local/bin/python

So I copied /usr/local/bin/python to /usr/bin/python and even after that I’m getting the same error. Any help is appreciated.

My answer:


Among other things, you removed the system Python package; yum is looking for the package which provides Python to be installed, not merely a Python binary. Reinstall the python package. And in the future, be very careful when removing packages.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.