What packages do I need to install to serve php pages from apache2 on Fedora 17?

chris asked:

This seems like it should be easy to answer, but as a php newbie, I can’t find out what exactly I need to install.

Some sites recommend just httpd, php and php-common; other suggestions include php-fpm and mod_fastcgi, as well as a bunch of php packages.

My goal is to be able to set up my dev machine and an amazon EC2 instance to be as similar as possible.

What do I need to install?

My answer:


On Fedora 17 it’s sufficient to install the php package. This pulls in all necessary dependencies, including Apache.

On previous versions of Fedora, and current versions of RHEL, you need to install mod_php.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.