can power supply affect I/O

user101289 asked:

I have a dev server machine running Ubuntu 12.04. For a long while it’s been throwing intermittent errors where it would suddenly tell me “File system is read only” or drop into a GRUB error console on boot. I’ve done disk checks, bad blocks, etc. and no real problems with the main SATA drive were detected.

Finally the drive would not be detected at all– but neither would other drives I plugged in (via SATA).

I plugged the supposedly “bad” drive into another server and it worked fine, no issues, for days– so I assumed the motherboard had a bad SATA controller, and replaced the motherboard with an identical model.

I replaced the drive into the original machine with the new motherboard, rebooted– and the same issues– I/O errors, failure to read the drive at all, dropping into GRUB, etc.

I’m wondering if there could be some other issue with this machine, that’s not related to the drive– possibly power supply?

Thanks for ideas

EDIT:

I replaced the power supply with a brand new 500W supply. Same issues. Removed the suspect drive, and used a brand new one– went to do a fresh install of Ubuntu, and the installer crashed with an error warning of a “read only file system”.

What could this be? I’ve already swapped out the HD, power supply and mobo. What’s left? Is the machine just cursed?

My answer:


Yes. If your drive doesn’t consistently get good power, it can’t really spin the platters at a consistent rate, resulting in intermittent inexplicable read errors.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.