How to install 64bit version of Mongodb

slownage asked:

How can I install the 64bit (x86_64) version of MongoDB?

I’ve specified in the 10gen.repo the 64bit:

baseurl=http://downloads-distro.mongodb.org/repo/redhat/os/x86_64

But when I run:

yum install mongo-10gen mongo-10gen-server

It’s the 32bit (see the i686) that it’s set to be installed.

Failed to set locale, defaulting to C
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.fdcservers.net
 * epel: mirror.steadfast.net
 * extras: mirror.fdcservers.net
 * rpmforge: mirror.rit.edu
 * updates: mirror.fdcservers.net
10gen                                                                                                                          |  951 B     00:00     
Not using downloaded repomd.xml because it is older than what we have:
  Current   : Tue Oct 30 15:55:02 2012
  Downloaded: Tue Oct 30 15:54:51 2012
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package mongo-10gen.i686 0:2.2.1-mongodb_1 will be installed
---> Package mongo-10gen-server.i686 0:2.2.1-mongodb_1 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

======================================================================================================================================================
 Package                                    Arch                         Version                                  Repository                     Size
======================================================================================================================================================
Installing:
 mongo-10gen                                i686                         2.2.1-mongodb_1                          10gen                          42 M
 mongo-10gen-server                         i686                         2.2.1-mongodb_1                          10gen                         6.5 M

Transaction Summary
======================================================================================================================================================
Install       2 Package(s)

Total download size: 48 M
Installed size: 118 M

I think I know why it want’s to install the 32bit version: the first time I’ve made the 10gen.repo file I had in there the 32bit link specified, and installed the 32bit, which later I’ve deleted.

Maybe something has been cached.
Could someone help me out with this.

My answer:


Yes, it appears to be a caching issue:

10gen                                                                                                                          |  951 B     00:00     
Not using downloaded repomd.xml because it is older than what we have:
  Current   : Tue Oct 30 15:55:02 2012
  Downloaded: Tue Oct 30 15:54:51 2012

Clear out your yum cache and then try again.

yum clean all

View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.