I am running OpenSUSE 10.1 SLES – Can I install non-Novell distributed packages?

Darius asked:

I have inherited an OpenSUSE 10.1 SLES box, with several virtual SLES machines running under it. The subscription for the regular, Novell-provided updates has expired. Can I circumvent renewing this subscription and install my own software, via my own repositories (e.g. Packman)?

As it stands, I cannot update or install any new software. When I attempt to directly install an RPM file, I am told by the computer that the “program is already installed”. Or when I attempt to add a new repo through either Yast2 or Zypper, I am told that it can’t use the repo_data.xml file that it found. Something tells me that Novell doesn’t want me updating this box without a subscription – any way around it?

Darius

UPDATE:
When trying to install an RPM: http://i.imgur.com/NjdlZ.png I get this false message.

My answer:


In essence, your options are:

  • Pay for SLES.
  • Switch to another distribution.

If you really want to be running SLES, then you have to have the subscription in order to gain access to SLES packages. Unfortunately OpenSUSE is reported to be not exactly binary compatible, and so it’s not guaranteed that RPMs taken from it, or any other RPM-based distribution, will work exactly properly. (RPM is just a package format; it doesn’t guarantee that what’s inside the package will work for you!)

That said, it is possible to upgrade a SLES 10.x box to OpenSUSE 11.x by doing an upgrade through the OpenSUSE installation media. This of course requires a maintenance window, and plenty of testing beforehand to ensure that your applications will run under OpenSUSE 11.x.

You could also take this opportunity to switch to a different distribution which might better fit your business needs.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.