installing php .deb files

slik asked:

I am using dotdeb.org php 5.4.8
http://archives.dotdeb.org/dists/squeeze/php5/5.4.8/binary-amd64/

I download all the files on to my box and run the following

cd /tmp/php-deb-5.4.8
dpkg -i php5-common_5.4.8-1~dotdeb.0_amd64.deb
dpkg -i --force-depends *.deb
apt-get install -f

I am running this box on ec2 and using my chef recipe for installation but the problem is i get an error

Processing triggers for php5-fpm ...
* Restarting PHP5 FastCGI Process Manager php5-fpm                                                                                                                                 [fail] 
Errors were encountered while processing:
php5-mysql

Any idea?

My answer:


Don’t install the packages manually. You had to explicitly ignore a bunch of warnings telling you to not do what you just did or things would break, and that’s why it isn’t working.

To fix the problem, follow the instructions to add dotdeb.org to your apt sources, and then use apt-get to install the desired packages.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.