v6tov4 in Linux?

DOSSTONED asked:

I have a server which runs Debian system. I use pptpd for VPN services. But pptpd can only response to IPv4 traffic and ignore IPv6 traffic. Is it possible to establish VPN connection using IPv6?(That is, pptp over IPv6, NOT IPv6 over pptp)

My answer:


Poptop doesn’t seem to have any support for IPv6. And its maintainers recommend you don’t use it anyway, for security reasons.

PPTP is known to be a faulty protocol. The designers of the protocol, Microsoft, recommend not to use it due to the inherent risks. Lots of people use PPTP anyway due to ease of use, but that doesn’t mean it is any less hazardous. The maintainers of PPTP Client and Poptop recommend using OpenVPN (SSL based) or IPSec instead.

Recent versions of OpenVPN support IPv6, so that’s probably your best bet during the transition.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.