unable to install MySql Workbench

Y.E.P asked:

When I try to install MySql Workbench using the yum command :

yum install mysql-workbench-gpl-5.2.45-1fc17.i686.rpm

I get these errors :

Error: Package: mysql-workbench-gpl-5.2.45-1fc17.i686 (/mysql-workbench-gpl-5.2.45-1fc17.i686)
       Requires: /bin/python
Error: Package: mysql-workbench-gpl-5.2.45-1fc17.i686 (/mysql-workbench-gpl-5.2.45-1fc17.i686)
       Requires: libzip.so.2
Error: Package: mysql-workbench-gpl-5.2.45-1fc17.i686 (/mysql-workbench-gpl-5.2.45-1fc17.i686)
       Requires: libctemplate.so.2
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

What are these errors and what do I do to install this MySql GUI tool ?

My answer:


You’re trying to install a package for Fedora 17 on Fedora 16. This isn’t guaranteed to work, since the package versions for the package’s dependencies may change from one version to the next. These dependencies do exist on my Fedora 17 box, though at least one of them appears to be different or missing on Fedora 16.

You have three options:

  1. The preferred option: Upgrade to Fedora 17 or Fedora 18 (which is being released a few days from now). Fedora 16 will be EOL’d a month after the release of Fedora 18. After upgrading, you can then install the package.

  2. Find the equivalent RPM for Fedora 16 and install it.

  3. If no such RPM exists, rebuild the package on your system from the source RPM.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.