Exim spaming errors to log and doesn't send mail to several domains

Korben asked:

I have a server with CentOS 5.6 installed on it.
It has working mail server of exim + dovecot + mysql + roundcube.

My log file /var/log/exim/main.log is already of 3 Gb and continues to grow. It consists of such entries:

2013-03-12 18:09:42 1UEaWr-0003VI-Ts == root@mail.mydomain.com R=dnslookup defer (-1): host lookup did not complete
2013-03-12 18:09:42 1UEIcr-0005k3-Mc == root@mail.mydomain.com R=dnslookup defer (-1): host lookup did not complete
2013-03-12 18:09:42 1UE8ro-00011h-8S == root@mail.mydomain.com R=dnslookup defer (-1): host lookup did not complete
2013-03-12 18:09:42 1UEtDl-0006jP-8h == root@mail.mydomain.com R=dnslookup defer (-1): host lookup did not complete
2013-03-12 18:09:43 1UEipX-0001Ub-5z == root@mail.mydomain.com R=dnslookup defer (-1): host lookup did not complete
2013-03-12 18:09:43 1UESyw-0003mv-E0 == root@mail.mydomain.com R=dnslookup defer (-1): host lookup did not complete
2013-03-12 18:09:43 1UEA9c-0005gO-71 == root@mail.mydomain.com R=dnslookup defer (-1): host lookup did not complete
2013-03-12 18:09:43 1UE7rt-00074q-2G == root@mail.mydomain.com R=dnslookup defer (-1): host lookup did not complete
2013-03-12 18:09:43 1UEkev-0004od-HA == root@mail.mydomain.com R=dnslookup defer (-1): host lookup did not complete
2013-03-12 18:09:43 1UEsBj-0002dM-Mt == root@mail.mydomain.com R=dnslookup defer (-1): host lookup did not complete

I understand that it’s because of mail.mydomain.com is not FQDN or real domain name at all. But where it takes from? I’ve checked /etc/exim/exim.conf and every file in /etc/ but couldn’t find this domain string. Besides, I’ve checked vexim database’s tables – no results. How can I change it?

Then, when I try to send mail, I’m getting this error in log (I’ve replaced real mail and ip addresses):

2013-03-12 18:13:30 1UFJGl-0004c9-2X == rcpt@to.com R=dnslookup T=remote_smtp defer (-45): SMTP error from remote mail server after MAIL FROM:<root@mail.mydomain.com> SIZE=1406: host mail2.to.com [x1x.x1x.x1x.x1x]: 451 4.1.8 Sender address <root@mail.mydomain.com> domain does not resolve
2013-03-12 18:14:34 1UFJGl-0004c9-2X SMTP error from remote mail server after RCPT TO:<rcpt@to.com>: host mail.to.com [x1x.x1x.x1x.x1x]: 450 4.7.1 Client host rejected: cannot find your hostname, [x2x.x2x.x2x.x2x]

I suppose the source of this problem is the same. But can’t find the solution.
I assume my problem is to replace default FROM field for exim (root@mail.mydomain.com) with something like no-reply@realfqdndomainname.com

Any help? Thanks.

My answer:


You didn’t set reverse DNS (PTR record) for your IP address correctly.

Set a PTR record for your IP address which resolves to a valid hostname, whose A record resolves to the same IP address.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.