I am unable to install php5-apc on my Ubuntu server

jnbdz asked:

I am unable to install php5-apc.

I don’t seem to get any errors.

root@applications-server-1:~# aptitude install php5-apc
The following NEW packages will be installed:
 php5-apc{b} 
0 packages upgraded, 1 newly installed, 0 to remove and 57 not upgraded.
Need to get 64.6 kB of archives. After unpacking 168 kB will be used.
The following packages have unmet dependencies:
 php5-apc : Depends: php5-common (= 5.3.22-1~dotdeb.0) but 5.4.6-1ubuntu1.1 is installed.
The following actions will resolve these dependencies:

 Keep the following packages at their current version:
 1)     php5-apc [Not Installed]                           



 Accept this solution? [Y/n/q/?] Y
 No packages will be installed, upgraded, or removed.
 0 packages upgraded, 0 newly installed, 0 to remove and 57 not upgraded.
 Need to get 0 B of archives. After unpacking 0 B will be used.

 root@applications-server-1:~# aptitude install php5-common
 No packages will be installed, upgraded, or removed.
 0 packages upgraded, 0 newly installed, 0 to remove and 57 not upgraded.
 Need to get 0 B of archives. After unpacking 0 B will be used.

Here is information about my OS:

  • Distributor ID: Ubuntu
  • Description: Ubuntu 12.10
  • Release: 12.10
  • Codename: quantal

I am using PHP-FPM (PHP Version 5.4.6-1ubuntu1.1).

So can I do to install PHP5-APC?

My answer:


Remove the dotdeb.org repository from your apt sources. This repository was designed for Debian systems and is not intended for (and does not work with) Ubuntu.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.