openVPN centOS 6.4 64bit dependency issues

Jony asked:

Everytime I download the openVPN rpm (http://mirror.its.sfu.ca/mirror/CentOS-Third-Party/epel/6/x86_64/openvpn-2.2.2-1.el6.x86_64.rpm) and try to install it, I’m running into dependency issues.

What I did:

wget http://mirror.its.sfu.ca/mirror/CentOS-Third-Party/epel/6/x86_64/openvpn-2.2.2-1.el6.x86_64.rpm
rpm -ivh openvpn-2.2.2-1.el6.x86_64.rpm

Now everytime I get more and more messages like

liblzo2.so.2 is needed by openvpn-2.2.2-1.el6.i686
libpkcs11-helper.so.1 is needed by openvpn-2.2.2-1.el6.i686

and more alot of them..

and like

glibc = 2.14.90-14 is needed by glibc-common-2.14.90-14.x86_64

Then installed it ^..

and then I get this…

glibc-common = 2.14.90-14 is needed by glibc-2.14.90-14.x86_64

Tired using centOS 5 32bit, and 6.4 32, 64 bit.
Everything is the same, no change.

What is the problem?

My answer:


The problem is you randomly grabbed an RPM off the Internet. This is a very bad idea overall.

It appears OpenVPN is in the EPEL repository, which you should already have installed. So once you install EPEL on your system, you can just do:

yum install openvpn

like any other package.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.