How to enable pdo_mysql with mysql 5.6 from binaries

pmm asked:

I have installed PHP 5.4 from package (yum install php) and MySQL 5.6 from binaries (http://opensourcedbms.com/dbms/installing-mysql-5-6-on-cent-os-6-3-redhat-el6-fedora/), but can’t get get pdo_mysql enabled.

Running yum install php-mysql generates errors, because there is a newer version of MySQL already installed.

Running yum install pdo got me PDO and pdo_sqlite, but not pdo_mysql. There is no pdo_mysql.so in php extensions directory

My answer:


pdo_mysql is part of the php-mysql package. You can’t install this package because you installed PHP binaries from a third party repository which were built against MySQL 5.5.

At the moment the only solution is to rebuild the php package yourself. No third party repos that I’m aware of provide PHP 5.4 built against MySQL 5.6.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.