phpmyadmin vs EPEL

dockeryZ asked:

I am running Centos 6.0 (Final) , the i386 version.

I am trying my hardest to get a decent LAMP Server running, with phpMyAdmin.

I can get everything installed just fine, MySQL, Apache2 (httpd), PHP 5.x, etc…, but when I get to reading some tutorials on installing phpMyAdmin, I fail miserably. Each tutorial I read mentions enabling the EPEL/REMI repo.. As soon as I add this repo I am not able to use yum anymore.

I continue to get this error message

[root@username tmp]# yum update
Loaded plugins: aliases, fastestmirror
Loading mirror speeds from cached hostfile
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 285, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 136, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 434, in doCommands
    self._getTs(needTsRemove)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 99, in _getTs
    self._getTsInfo(remove_only)
  File "/usr/lib/python2.6/site-packages/yum/depsolve.py", line 110, in _getTsInfo
    pkgSack = self.pkgSack
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 887, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 669, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 279, in populateSack
    self.doSetup()
  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 105, in doSetup
    self.ayum.plugins.run('postreposetup')
  File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 184, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/fastestmirror.py", line 202, in postreposetup_hook
    all_urls = FastestMirror(all_urls).get_mirrorlist()
  File "/usr/lib/yum-plugins/fastestmirror.py", line 369, in get_mirrorlist
    self._poll_mirrors()
  File "/usr/lib/yum-plugins/fastestmirror.py", line 413, in _poll_mirrors
    pollThread.start()
  File "/usr/lib/python2.6/threading.py", line 474, in start
    _start_new_thread(self.__bootstrap, ())
thread.error: can't start new thread

It’s driving me insane. I am using a VPS so everytime this happens I am easily able to restart from scratch, but after so many times with the same results I have no clue where I am going wrong.

My answer:


Your (very small, and probably crappy OpenVZ) VPS has run out of memory.

You can try working around this by disabling the (probably strictly unnecessary) yum plugins, to reduce the memory usage:

yum --disableplugin=* update

If that doesn’t get you any farther, you’ll have to stop some services to free up memory.

If you still can’t get anywhere, you’ll have to upgrade your VPS package.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.