failed to get a socket / probably libapr1 error

shym asked:

I started configuring my server to use redmine on it.
I tried a lot of approaches and the last one fast to try passenger.

When I run passenger-install-apache2-module It said that I am missing some packages.
After installing some of them I wanted to check how the server works. And I can’t restart it.
The message I get is

[Thu Aug 01 15:15:22 2013] [crit] (22)Invalid argument: alloc_listener: failed to get a 

socket for x.x.x.x
Syntax error on line 9 of /etc/apache2/ports.conf:
Listen setup failed
Action 'configtest' failed.
The Apache error log may have more information.
 failed!

the x.x.x.x <- is an actual IP, I just crossed it out.
On the lined 9 of that config is

Listen x.x.x.x:80

It worked before perfectly.
I read that the solution to this problem is to build libapr1 by myself but I can’t do this. I get some missing packages errors and when I try to install them there are more missing packages and the final one is not found by apt-get.

This is the solution I found but I can’t execute that code.
Apache in linux-vserver won't start, can't create socket

I am totaly new to this so please ask me anything that can help You understand my problem.

EDIT:
The error was made because the apache server was updated without updating the kernel.

My answer:


Apache was already running. You must stop the existing server before starting it again.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.