Upgrading error

ikerib asked:

When I do apt-get update // apt-get upgrade i received this error whatever I do:

root@debian:~# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 curl : Depends: libcurl3 (= 7.26.0-1+wheezy3) but 7.21.0-2.1+squeeze2 is installed
 multiarch-support : Depends: libc6 (>= 2.13-5) but 2.11.3-4 is installed
E: Unmet dependencies. Try using -f.
root@debian:~#

This is not my server so I don´t know what is installed inside, the only thing I know is that I need to upgrade the php from 5.2 minimum to 5.3. The told me that Zend Server is installed but I don´t know which version either. The first thing I tried is this and everytime I get this error.
cat /etc/issue says:
Debian GNU/Linux 6.0 n l

This is my /etc/apt/sources.list:

root@debian:~# cat /etc/apt/sources.list

# deb cdrom:[Debian GNU/Linux 6.0.6 _Squeeze_ - Official i386 NETINST Binary-1 20120930-15:55]/ squeeze main

#deb cdrom:[Debian GNU/Linux 6.0.6 _Squeeze_ - Official i386 NETINST Binary-1 20120930-15:55]/ squeeze main

deb http://ftp.es.debian.org/debian/ squeeze main
deb-src http://ftp.es.debian.org/debian/ squeeze main

deb http://security.debian.org/ squeeze/updates main
deb-src http://security.debian.org/ squeeze/updates main

# squeeze-updates, previously known as 'volatile'
deb http://ftp.es.debian.org/debian/ squeeze-updates main
deb-src http://ftp.es.debian.org/debian/ squeeze-updates main
deb http://ftp2.de.debian.org/debian squeeze main non-free
deb http://repos.zend.com/zend-server/deb server non-free
root@debian:~#

and this is my output using apt-get install -f curl:

root@debian:~# apt-get install -f curl
Reading package lists... Done
Building dependency tree
Reading state information... Done
curl is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 curl : Depends: libcurl3 (= 7.26.0-1+wheezy3) but 7.21.0-2.1+squeeze2 is to be installed
 multiarch-support : Depends: libc6 (>= 2.13-5) but 2.11.3-4 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I answered:

The original error also gives the solution:

You might want to run 'apt-get -f install' to correct these.

If you haven’t seen this before, you have to run exactly that command. Doing otherwise, you get:

Try 'apt-get -f install' with no packages (or specify a solution).

This usually fixes the problem.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.