Disable Perl warnings for missing qw outer parentheses

PP. asked:

Since upgrading Debian recently I’ve had Perl whining about not having extra parentheses around the qw operator.

As a Systems Administrator this is unacceptable. It is breaking mod_perl applications left, right, and centre.

How can I run Perl with this warning disabled? Is there a flag I can run with the Perl interpreter? Note that editing source is not an option.


I answered:

As a system administrator I find bad code unacceptable.

The best answer, of course, is to fix the offending perl scripts.

If your business won’t let you fix the offending perl scripts, then don’t upgrade Debian.

You have risks either way.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.