Error installing php-mysqlnd

Zero Wing asked:

I’ve been trying to install phpmysqlnd, but I’m not sure what’s going wrong.

This is on a CentOS system.

I run the commands:

yum remove php-mysql

yum install php-mysqlnd

The first one is a success, but the second errors out, saying:

Error: Package: php-mysqlnd-5.3.27-1.el6.x86_64 (CentALT)
       Requires: php-pdo(x86-64) = 5.3.27-1.el6
       Installed: php-pdo-5.3.3-23.el6_4.x86_64 (@updates)
           php-pdo(x86-64) = 5.3.3-23.el6_4
       Available: php-pdo-5.3.3-22.el6.x86_64 (base)
           php-pdo(x86-64) = 5.3.3-22.el6

I’m honestly not too familiar with these kinds of installs, so any help with getting this to work would be greatly appreciated, thanks!

My answer:


You’re trying to install a PHP module provided by a third party repository; to do this requires that your version of PHP be in sync with that provided by the repository. Unfortunately this couldn’t be done because the third party repository is missing the necessary packages. To resolve this you will need to contact the package or repository maintainer.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.