Amazon linux package conflict

nosferatu asked:

I was trying install php55-fpm on amazon linux, but there is a package conflict with php-common. How solve this issue ?

[ec2-user@ip-10-0-12-54 ~]$ sudo yum install php55-fpm
Loaded plugins: priorities, update-motd, upgrade-helper
amzn-main/latest                                                                                                                                   | 2.1 kB     00:00     
amzn-updates/latest                                                                                                                                | 2.3 kB     00:00     
Resolving Dependencies
--> Running transaction check
---> Package php55-fpm.x86_64 0:5.5.7-1.61.amzn1 will be installed
--> Processing Dependency: php55-common(x86-64) = 5.5.7-1.61.amzn1 for package: php55-fpm-5.5.7-1.61.amzn1.x86_64
--> Running transaction check
---> Package php55-common.x86_64 0:5.5.7-1.61.amzn1 will be installed
--> Processing Dependency: php55-pecl-jsonc(x86-64) for package: php55-common-5.5.7-1.61.amzn1.x86_64
--> Processing Dependency: libzip.so.2()(64bit) for package: php55-common-5.5.7-1.61.amzn1.x86_64
--> Running transaction check
---> Package libzip.x86_64 0:0.10.1-1.3.amzn1 will be installed
---> Package php55-pecl-jsonc.x86_64 0:1.3.2-1.9.amzn1 will be installed
--> Processing Dependency: /usr/bin/pecl for package: php55-pecl-jsonc-1.3.2-1.9.amzn1.x86_64
--> Processing Dependency: libjson-c.so.2()(64bit) for package: php55-pecl-jsonc-1.3.2-1.9.amzn1.x86_64
--> Running transaction check
---> Package json-c.x86_64 0:0.11-4.5.amzn1 will be installed
---> Package php-pear.noarch 1:1.9.4-20.15.amzn1 will be installed
--> Processing Dependency: php-cli for package: 1:php-pear-1.9.4-20.15.amzn1.noarch
--> Processing Dependency: php-posix for package: 1:php-pear-1.9.4-20.15.amzn1.noarch
--> Processing Dependency: php-xml for package: 1:php-pear-1.9.4-20.15.amzn1.noarch
--> Running transaction check
---> Package php-cli.x86_64 0:5.3.28-1.2.amzn1 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.28-1.2.amzn1 for package: php-cli-5.3.28-1.2.amzn1.x86_64
---> Package php-process.x86_64 0:5.3.28-1.2.amzn1 will be installed
---> Package php-xml.x86_64 0:5.3.28-1.2.amzn1 will be installed
--> Running transaction check
---> Package php-common.x86_64 0:5.3.28-1.2.amzn1 will be installed
--> Processing Conflict: php55-common-5.5.7-1.61.amzn1.x86_64 conflicts php-common < 5.5.7-1.61.amzn1
--> Finished Dependency Resolution
Error: php55-common conflicts with php-common-5.3.28-1.2.amzn1.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[ec2-user@ip-10-0-12-54 ~]$ cat /etc/issue
Amazon Linux AMI release 2013.09
Kernel r on an m

This is a new Amazon linux box. There is no php at all.

Thanks

My answer:


OK, here we see that the dependencies are trying to bring in php-pear, which depends on php-common, which is the wrong version; I would be expecting php55-common, and possibly php55-pear packages to be pulled in here.

This isn’t something you can really resolve; the repository you’re trying to install from has broken packages. (Unfortunately this poor quality packaging is all too common with Amazon Linux, which is one reason I recommend against using it.) You’ll need to contact Amazon, or better yet, use anything but Amazon Linux.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.