Cpanel nameserver error? Missing nameservers reported by your nameservers

Mike asked:

I’ve got a new dedicated leaseweb server with WHM/Cpanel. There’s only 1 IP.
I’ve registered the main domain iworldcreation.com at whois.com. It has two private nameservers assigned: ns1.iworldcreation.com and ns2.iworldcreation.com.

I also added two child name servers:
ns1.iworldcreation.com pointing to 95.211.9.24
ns2.iworldcreation.com also pointing to the same IP 95.211.9.24

I know two ns’es pointing to the same IP is nonsense, but still that’s how I configured the domain @ whois.com.

On WHM I’ve setup BIND and added zones, but I still get errors like:
Missing nameservers reported by your nameservers when I check the nameserver setup via intodns.

Can someone advise where the problem is and what I need to do to fix it?

Mike

My answer:


Did you read the rest of the output from intodns?

ERROR: One or more of your nameservers did not respond:
The ones that did not respond are:
95.211.9.24

Try starting the DNS server and making sure it isn’t firewalled or misconfigured.

Your nameserver is having some sort of problem:

$ host -t ns iworldcreation.com. 95.211.9.24
Using domain server:
Name: 95.211.9.24
Address: 95.211.9.24#53
Aliases: 

Host iworldcreation.com not found: 2(SERVFAIL)

So you should check your logs and fix that.

And you’re really going to need more than one nameserver here if you intend for this to be a serious web host, but you seem to know that already.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.