opendkim requires libcrypto

Thomas Schlabomas asked:

I am trying to install opendkim. For that, I used rpm to install epel, then did yum install opendkim. However, I get the following dependency errors:

Error: Package: opendkim-2.9.0-2.el6.x86_64 (epel)
Requires: libcrypto.so.10(OPENSSL_1.0.1)(64bit)

Error: Package: libopendkim-2.9.0-2.el6.x86_64 (epel)
Requires: libcrypto.so.10(libcrypto.so.10)(64bit)

Error: Package: opendkim-2.9.0-2.el6.x86_64 (epel)
Requires: libssl.so.10(libssl.so.10)(64bit)

Error: Package: opendkim-2.9.0-2.el6.x86_64 (epel)
Requires: libcrypto.so.10(libcrypto.so.10)(64bit)

As far as I can tell, this is because I’m running openssl 1.0.0, and it’s looking for 1.0.1. I feel like I should update openssl, but I’m not sure how, and I’m a little nervous to do that. Can anyone tell me if this is in fact what I need to do? This may be a duplicate question but I don’t understand the answer: Why yum update PHP doesn't have required dependencies? CentOS 6 missing libcrypto and libssl

My answer:


You need to update your system.

RHEL (and CentOS) switched from OpenSSL 1.0.0 to 1.0.1 during the 6.4-6.5 cycle in order to resolve a years-long issue. As a result any programs which use OpenSSL had to be rebuilt for 6.5.

Since EPEL only tracks the latest point release, and its software is only guaranteed to run on the latest point release, you need to update to 6.5.

A simple yum --disableexcludes=all upgrade should take care of it.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.