dependency for php-mcypt from remi repo on Centos 6.5

mardon asked:

I install php 5.4 in my Centos 6.5 server withe remi repository. But if I want install php-mcrypt form this repository i obtain dependency error

 yum --enablerepo=remi install php-gd php-mcrypt
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.hexageek.com
 * extras: mirror.hexageek.com
 * remi: mirror5.layerjet.com
 * updates: mirror.hexageek.com
Setting up Install Process
Package php-gd-5.4.26-1.el6.remi.x86_64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package php-mcrypt.x86_64 0:5.4.26-1.el6.remi will be installed
--> Processing Dependency: libmcrypt.so.4()(64bit) for package: php-mcrypt-5.4.26-1.el6.remi.x86_64
--> Processing Dependency: libltdl.so.7()(64bit) for package: php-mcrypt-5.4.26-1.el6.remi.x86_64
--> Running transaction check
---> Package libtool-ltdl.x86_64 0:2.2.6-15.5.el6 will be installed
---> Package php-mcrypt.x86_64 0:5.4.26-1.el6.remi will be installed
--> Processing Dependency: libmcrypt.so.4()(64bit) for package: php-mcrypt-5.4.26-1.el6.remi.x86_64
--> Finished Dependency Resolution
Error: Package: php-mcrypt-5.4.26-1.el6.remi.x86_64 (remi)
           Requires: libmcrypt.so.4()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

My answer:


libmcrypt is in the EPEL repository, which you don’t seem to have installed. Install the EPEL repo and try again.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.