installing php-mysql on centos 6

OnlyMAJ asked:

I’ve installed MariaDB for my database and Nginx on my computer that running Centos 6 . when i want to install php-mysql driver i get this problem :

# yum install php-mysql

Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
 * base: centos.mirror.gtcomm.net
 * epel: fedora-epel.mirror.iweb.com
 * extras: mirror.agmn.ca
 * updates: centos.mirror.gtcomm.net
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php-mysql.x86_64 0:5.3.3-27.el6_5 will be installed
--> Processing Dependency: php-pdo(x86-64) for package: php-mysql-5.3.3-27.el6_5.x86_64
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: php-mysql-5.3.3-27.el6_5.x86_64
Package mysql-libs is obsoleted by MariaDB-shared, but obsoleting package does not provide for requirements
--> Processing Dependency: libmysqlclient.so.16()(64bit) for package: php-mysql-5.3.3-27.el6_5.x86_64
Package mysql-libs is obsoleted by MariaDB-shared, but obsoleting package does not provide for requirements
--> Running transaction check
---> Package php-mysql.x86_64 0:5.3.3-27.el6_5 will be installed
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: php-mysql-5.3.3-27.el6_5.x86_64
Package mysql-libs is obsoleted by MariaDB-shared, but obsoleting package does not provide for requirements
--> Processing Dependency: libmysqlclient.so.16()(64bit) for package: php-mysql-5.3.3-27.el6_5.x86_64
Package mysql-libs is obsoleted by MariaDB-shared, but obsoleting package does not provide for requirements
---> Package php-pdo.x86_64 0:5.3.3-27.el6_5 will be installed
--> Finished Dependency Resolution
Error: Package: php-mysql-5.3.3-27.el6_5.x86_64 (updates)
           Requires: libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.71-1.el6.x86_64 (base)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.73-3.el6_5.x86_64 (updates)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
Error: Package: php-mysql-5.3.3-27.el6_5.x86_64 (updates)
           Requires: libmysqlclient.so.16()(64bit)
           Available: mysql-libs-5.1.71-1.el6.x86_64 (base)
               libmysqlclient.so.16()(64bit)
           Available: mysql-libs-5.1.73-3.el6_5.x86_64 (updates)
               libmysqlclient.so.16()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

i also tried --skip-broken and rpm -Va --nofiles --nodigest but ro result

My answer:


You appear to have installed MariaDB from the packages provided by the project. You first need to install the equivalent MariaDB-compat RPM from MariaDB before you can install these packages. This package provides compatibility with distribution packages which are expecting the older version of MySQL which CentOS comes with.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.