x2Go dependency requires unavailable nx packages on CentOS 6.5

xtian asked:

I thought I’m at my wits ends trying to figure out how to resolve these dependencies…

[root@mrwizard yum.repos.d]# yum install x2goclient x2goserver
[...]
Error: Package: x2goclient-4.0.1.3-1.el6.i686 (epel)
           Requires: nxproxy
Error: Package: x2goagent-3.5.0.22-1.el6.i686 (epel)
           Requires: nxagent

Here is a pastebin with the full yum install output and my repolist.

I’ve investigated the installation on x2go site, I performed, in order, these steps to attempt the install:

  1. Activate EPEL
  2. And, I activated several other ‘testing’ repositories just in case.
  3. Add the X2Go repo to your yum configuration (is this part of ‘rhn-channel’?)
  4. The x2go announce list shows a current version on RHEL (4.0.1.13)–not by any means outdated.

Of course its all the more strange, because nxagent 3.5 is already installed and working on my system! And the FAQ at x2go implies they should work together “Nowadays the NX libs shipped with X2Go work as a replacement for the NXv3 that are not maintained by NoMachine anymore.”

Do you have CentOS or RedHat based server using x2Go? Can you explain what I’m missing

My answer:


The installation instructions you linked to gave two separate and distinct installation methods, one involving EPEL and the other involving OBS. You seem to have done both of them, but they are mutually exclusive.

To resolve the problem, remove the x2go repo file that you installed and try again using only EPEL.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.