"yum update" error. How to handle this?

Márcio asked:

I have an ec2 instance and I’m trying to update all packages.

But the problem is when I execute “yum update” it shows the message:

Transaction Check Error:
  file /usr/lib64/perl5/vendor_perl/Cwd.pm conflicts between attempted installs of perl-Cwd-2.21-1.2.el6.rf.x86_64 and perl-PathTools-3.40-3.4.amzn1.x86_64
  file /usr/lib64/perl5/vendor_perl/auto/Cwd/Cwd.so conflicts between attempted installs of perl-Cwd-2.21-1.2.el6.rf.x86_64 and perl-PathTools-3.40-3.4.amzn1.x86_64
  file /usr/share/man/man3/Cwd.3pm.gz conflicts between attempted installs of perl-Cwd-2.21-1.2.el6.rf.x86_64 and perl-PathTools-3.40-3.4.amzn1.x86_64

My Linux version is: 3.4.48-45.46.amzn1.x86_64 Red Hat 4.6.3-2

I tried to exclude “perl” from the updates, but the problem is that nginx need this perl update.

Any help how to handle this?
Thanks in advance!

My answer:


You have an incompatible repository “rpmforge”. This only works on RHEL and clones, and isn’t compatible with Amazon Linux (which used to be a RHEL clone, but isn’t anymore).

You have a couple of options:

  1. Remove the rpmforge repository and try again. Note that you might not be able to do this if you actually need packages from this repository.

  2. The preferred option: Stop using Amazon Linux. Our pages are full of questions from people whose problems were directly traceable to quality control problems in Amazon’s packages.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.