Yum update problems on AWS with missing requirements and duplicate sendmail

Christian asked:

I am running an AWS VM and tried:

sudo yum update

Result:

Error: Protected multilib versions: sendmail-8.14.4-8.12.amzn1.x86_64 != sendmail-8.14.4-7.9.amzn1.i386
 You could try using --skip-broken to work around the problem
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
kernel-2.6.34.7-56.40.amzn1.x86_64 has missing requires of mkinitrd
sendmail-8.14.4-8.11.amzn1.x86_64 is a duplicate with sendmail-8.14.4-7.9.amzn1.i386

I read else where to try this:

sudo yum --exclude=kernel* update

But same result.

This is a production server which I want to upgrade so I have to take special care. I was not the one preparing it. Looks like I use the amazon version of Red Hat 4.4.6-3.

Any suggestions how to fix this?

My answer:


Use yum distro-sync instead of yum update to fix package version mismatches in this scenario. This allows for packages to be downgraded if necessary to match the versions in the repositories.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.