MongoDB Mergelist error in Debian 6.0.9

user113920 asked:

We installed Ubiquiti UniFi 2.4.6 which installs Mongodb 10gen on Debian Squeeze 6.0.9. This was a clean install, with no other packages installed from the base install (other than SSH). I was able to successfully install both UniFi and Mongodb, but received the following when running an apt-get update:

Pertinent error:

**Reading package lists… Error!

**E: Encountered a section with no Package: header

E: Problem with MergeList /var/lib/apt/lists/downloads-distro.mongdb.org_repo_ubuntu-upstart_dists_dist_10gen_binary-i386_Packages

E: The package lists or status file could not be parsed or opened.****

I’ve ran a sudo rm /var/lib/apt/lists/* -vf followed by an apt-get clean && apt-get update with the same error appearing. (I did back up the lists directory. Any ideas?)

As an aside, I should mention, that I tried to remove unifi and it probably goes without saying it won’t uninstall.

Here’s a head of downloads-distro.mongdb.org_repo_ubuntu-upstart_dists_dist_10gen_binary-i386_Packages (removed the links)

mongdb.org
script src=”://www.google.(com)/adsense/domains/caf.js” type=”text/javascript” >
=”
://d1vbm0eveofcle.cloudfront.(net)/themes/assets/style.css” rel=”stylesheet” type=”text/css” media=”screen” />

=”*://d1vbm0eveofcle.cloudfront.(net)/themes/cleanPeppermintBlack/style5.css” rel=”stylesheet” type=”text/css” media=”screen” />

link=’*://fonts.googleapis.(com)/css?family=Libre+Baskerville:400,700′ rel=’stylesheet’ type=’text/css’>

root@:/var/l

Full apt-get update:

Get:1 *://security.debian.(org)squeeze/updates Release.gpg [836 B]

Ign *://security.debian.(org)/ squeeze/updates/main Translation-en

Ign *://security.debian.(org)/ squeeze/updates/main Translation-en_US

Hit *://ftp.us.debian.(org)squeeze Release.gpg

Ign *://ftp.us.debian.(org)/debian/ squeeze/main Translation-en

Ign *://ftp.us.debian.(org)/debian/ squeeze/main Translation-en_US

Get:2 *://ftp.us.debian.(org)squeeze-updates Release.gpg [836 B]

Get:3 *://security.debian.(org)squeeze/updates Release [86.9 kB]

Ign *://ftp.us.debian.org/debian/ squeeze-updates/main Translation-en

Ign *://ftp.us.debian.org/debian/ squeeze-updates/main Translation-en_US

Hit *://ftp.us.debian.(org)squeeze Release

Get:4 *://ftp.us.debian.(org)squeeze-updates Release [113 kB]

Hit *://www.ubnt.(com)squeeze Release.gpg

Ign *://www.ubnt.(com)/downloads/unifi/distros/deb/squeeze/ squeeze/ubiquiti Translation-en

Get:5 *://security.debian.(org)squeeze/updates/main Sources [172 kB]

Get:6 *://downloads-distro.mongdb.(org)dist Release.gpg

Ign *://www.ubnt.(com)/downloads/unifi/distros/deb/squeeze/ squeeze/ubiquiti Translation-en_US

Get:7 *://downloads-distro.mongdb.(org)/repo/ubuntu-upstart/ dist/10gen Translation-en

Get:8 *://downloads-distro.mongdb.(org)/repo/ubuntu-upstart/ dist/10gen Translation-en_US

Hit *://ftp.us.debian.(org)squeeze/main Sources

Hit *://ftp.us.debian.(org)squeeze/main i386 Packages

Get:9 *://security.debian.(org)squeeze/updates/main i386 Packages [457 kB]

Get:10 *://ftp.us.debian.(org)squeeze-updates/main Sources/DiffIndex [3,955 B]

Get:11 *://ftp.us.debian.(org)squeeze-updates/main i386 Packages/DiffIndex [3,955 B]

Get:12 *://ftp.us.debian.(org)squeeze-updates/main i386 Packages [5,228 B]

Get:13 *://downloads-distro.mongdb.(org)dist Release

Ign *://downloads-distro.mongdb.org dist Release

Hit *://www.ubnt.(com)squeeze Release

Get:14 *://downloads-distro.mongdb.(org)dist/10gen i386 Packages/DiffIndex

Get:15 *://downloads-distro.mongdb.(org)dist/10gen i386 Packages

Hit *://www.ubnt.(com)squeeze/ubiquiti i386 Packages

Fetched 882 kB in 1s (596 kB/s)

Reading package lists… Error!

E: Encountered a section with no Package: header

E: Problem with MergeList /var/lib/apt/lists/downloads-distro.mongdb.org_repo_ubuntu-upstart_dists_dist_10gen_binary-i386_Packages

E: The package lists or status file could not be parsed or opened.

My answer:


You tried to install MongoDB with the Ubuntu installation method, rather than the Debian installation method. Try again and this time use the correct installation method.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.