how to fix "Package pcre-6.6-6.el5_6.1.x86_64 already installed and latest version" alert need to update it to pcre-8.31?

Halku asked:

Goodafternoon,

I am trying to update my pcre-6.6-6.el5_6.1.x86_64 package to pcre-8.31 following is my steps to do so:

Step

1: cd /etc/yum.repos.d

  1. Made repository utter-ramblings.repo in it.

  2. Populated utter-ramblings.repo file with

    [utter-ramblings]
    name=Utter Ramblings
    baseurl=http://www.jasonlitka.com/media/EL5/i386/
    gpgkey=http://www.jasonlitka.com/media/RPM-GPG-KEY-jlitka
    enabled=1
    gpgcheck=1
    
  3. Then following command:

    yum install pcre
    

I got installation process started successfully but with following errors

    Transaction Check Error:
    file /usr/share/man/man1/pcregrep.1.gz from install of pcre-8.13-1.jason.2.i386   conflicts with file from package pcre-6.6-6.el5_6.1.x86_64

file /usr/share/man/man1/pcretest.1.gz from install of pcre-8.13-1.jason.2.i386 conflicts with file from package pcre-6.6-6.el5_6.1.x86_64

My OS at VPS info is: OS
Linux 2.6.18-028stab094.3

Kindly help me to resolve it.

My answer:


You’ve specified both the wrong distribution and the wrong architecture in your third party repository configuration.

.../EL5/i386/...

But, you’re running EL6 on x86_64!

So, instead, this should read:

.../EL6/x86_64/...

View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.