Can't install php-mysql module

Christopher Francisco asked:

First time using php 5.5 and well I’m getting a lot of headaches.

I can’t install php-mysql, I get the following error:

Error: Package: php-mysql-5.4.30-1.el6.remi.x86_64 (remi)
       Requires: php-pdo(x86-64) = 5.4.30-1.el6.remi
       Installed: php-pdo-5.5.14-2.el6.remi.x86_64 (@remi-php55)
           php-pdo(x86-64) = 5.5.14-2.el6.remi
       Available: php-pdo-5.3.3-26.el6.x86_64 (base)
           php-pdo(x86-64) = 5.3.3-26.el6
       Available: php-pdo-5.3.3-27.el6_5.x86_64 (updates)
           php-pdo(x86-64) = 5.3.3-27.el6_5
       Available: php-pdo-5.4.29-3.el6.remi.x86_64 (remi)
           php-pdo(x86-64) = 5.4.29-3.el6.remi
       Available: php-pdo-5.4.30-1.el6.remi.x86_64 (remi)
           php-pdo(x86-64) = 5.4.30-1.el6.remi
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

What do I do?

My answer:


You forgot to enable the remi-php55 repository from which you intended to get the packages.

You should make this persistent by editing the repo configuration file /etc/yum.repos.d/remi.repo and ensuring that the remi and remi-php55 repos are enabled.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.