Mail Server Running but not receiving emails

Archie Makuwa asked:

I am running Ubuntu and I am trying to setup my mail server using ISPConfig 3. Here is the error I am getting:

Mail Queue (Server : droplet.domain.co.za)
Data from: 2014-07-16 12:40
-Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
0D0FA25451 627 Wed Jul 16 03:21:02 root@droplet.domain.co.za
(connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
archie@domain.co.za

AC0AF23289 628 Wed Jul 16 12:19:01 root@droplet.domain.co.za
(mail transport unavailable)
moshidi@domain.co.za

AE3462545B 679 Wed Jul 16 06:55:19 root@droplet.domain.co.za
(mail transport unavailable)
root@droplet.domain.co.za

50C5425443 679 Wed Jul 16 01:24:04 amavis@droplet.domain.co.za
(connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
amavis@droplet.domain.co.za

-- 3 Kbytes in 4 Requests.

NB: domain (my domain is not domain) 

Whenever I sent emails to the created mailboxes, they do not come through. An error from my gmail account is as followS:

Technical details of temporary failure:

The recipient server did not accept our requests to connect. 
Learn more at http://support.google.com/mail/bin/answer.py?answer=7720
[(0) domain.co.za. [192.xxx.xxx.xx]:25: Connection dropped]

My answer:


Whatever service you configured to run on port 10024 is not running. Inspect your /etc/postfix/master.cf to find out what service it is, if you don’t already know, and then start the service.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.