Can't install nginx using epel repo on Centos 7 (64bit)

Aditya K asked:

I’ve just built a 64 bit Centos server and I’m trying to install NGINX on it. Using the epel 7 (beta) repo I get the following error when trying to install:

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.as29550.net
 * epel: mirror.vorboss.net
 * extras: centos.hyve.com
 * updates: centos.mirroring.pulsant.co.uk
Resolving Dependencies
--> Running transaction check
---> Package nginx.x86_64 0:1.0.15-5.el6 will be installed
--> Processing Dependency: perl(:MODULE_COMPAT_5.10.1) for package: nginx-1.0.15-5.el6.x86_64
--> Processing Dependency: libpcre.so.0()(64bit) for package: nginx-1.0.15-5.el6.x86_64
--> Finished Dependency Resolution
Error: Package: nginx-1.0.15-5.el6.x86_64 (epel)
           Requires: libpcre.so.0()(64bit)
Error: Package: nginx-1.0.15-5.el6.x86_64 (epel)
           Requires: perl(:MODULE_COMPAT_5.10.1)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Has anyone managed to install NGINX via yum successfully?

My answer:


You didn’t install the EPEL 7 repository. That’s the EPEL 6 repository. Remove it and try again.

Better yet, install nginx from their own repositories to ensure that you stay up to date with critical and less critical upstream fixes.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.