sudo yum install httpd is throwing errors

cppit asked:

Hello this is the command im typing and its returning the error you see, any suggestions please

[ec2-user@ip-172-31-41-46 ~]$ sudo yum install httpd


Loaded plugins: priorities, update-motd, upgrade-helper
Resolving Dependencies
--> Running transaction check
---> Package httpd.x86_64 0:2.2.27-1.3.amzn1 will be installed
--> Processing Dependency: httpd-tools = 2.2.27-1.3.amzn1 for package: httpd-2.2.27-1.3.amzn1.x86_64
--> Running transaction check
---> Package httpd-tools.x86_64 0:2.2.27-1.3.amzn1 will be installed
--> Processing Conflict: httpd24-2.4.10-1.59.amzn1.x86_64 conflicts httpd < 2.4.10
--> Processing Conflict: httpd24-tools-2.4.10-1.59.amzn1.x86_64 conflicts httpd-tools < 2.4.10
--> Finished Dependency Resolution
Error: httpd24-tools conflicts with httpd-tools-2.2.27-1.3.amzn1.x86_64
Error: httpd24 conflicts with httpd-2.2.27-1.3.amzn1.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[ec2-user@ip-172-31-41-46 ~]$

when I do yum install –skip-broken httpd it returns :

Packages skipped because of dependency problems:
    httpd-2.2.27-1.3.amzn1.x86_64 from amzn-updates
    httpd-tools-2.2.27-1.3.amzn1.x86_64 from amzn-updates

My answer:


You are trying to install the httpd package, containing version 2.2 of Apache, but you already have httpd24, containing version 2.4 of Apache, installed.

Before doing anything else, first decide which version you actually want.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.