How to install Foreman on Centos 6?

Alfred asked:

Attempt

According to this documentation, Puppet should be installed before installing Foreman.

Puppet

sudo rpm -ivh http://yum.puppetlabs.com/el/6.4/products/x86_64/puppetlabs-release-6-11.noarch.rpm
sudo yum -y install puppet

[vagrant@localhost ~]$ puppet --version
3.7.1

Foreman

sudo yum -y install http://yum.theforeman.org/releases/1.1/el6/x86_64/foreman-release.rpm
sudo yum -y install foreman-installer

Result

--> Finished Dependency Resolution
Error: Package: rubygem-apipie-bindings-0.0.8-4.el6.noarch (foreman)
           Requires: rubygem(mime-types) < 2.0.0
Error: Package: rubygem-rest-client-1.6.7-2.el6.noarch (foreman)
           Requires: rubygem(mime-types) >= 1.16
Error: Package: rubygem-apipie-bindings-0.0.8-4.el6.noarch (foreman)
           Requires: rubygem(fastercsv)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Attempt Two

Checking the error message, the idea was to try to fix the dependency issues by trying to install the following packages:

rubygem mime-types < 2.0.0
rubygem mime-types >= 1.16
rubygem fastercsv

by issuing the following commands:

sudo gem install mime-types -v 1.25.1
sudo gem install gem install fastercsv

Result Two

mime-types

[vagrant@localhost ~]$ sudo gem install mime-types -v 1.25.1
Successfully installed mime-types-1.25.1
1 gem installed

fastercsv

[vagrant@localhost ~]$ sudo gem install gem install fastercsv
ERROR:  Could not find a valid gem 'gem' (>= 0) in any repository
ERROR:  Could not find a valid gem 'install' (>= 0) in any repository
Successfully installed fastercsv-1.5.5
1 gem installed
Installing ri documentation for fastercsv-1.5.5...
Installing RDoc documentation for fastercsv-1.5.5...

Foreman

sudo yum -y install foreman-installer

Although the missing packages were installed using gem install the issue persists.

My answer:


You forgot to install and enable the EPEL repository. Do that, and then try the Foreman installation again.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.