Danijel J asked:
I followed the guide located here to install PHP 5.6 with Apache on CentOS 7.
Everything went along smoothly.
I now need to install PHP-SOAP and it’s gave me dependancy conflicts. So I used this guide here to update my server repositories to include webtatic and it’s now doing this:
$ yum --assumeyes install php56w-soap Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * Webmin: download.webmin.com * base: centos.mirror.uber.com.au * epel: epel.mirror.digitalpacific.com.au * extras: centos.mirror.crucial.com.au * updates: centos.mirror.crucial.com.au * webtatic: us-east.repo.webtatic.com Resolving Dependencies --> Running transaction check ---> Package php56w-soap.x86_64 0:5.6.2-1.w7 will be installed --> Processing Dependency: php56w-common(x86-64) = 5.6.2-1.w7 for package: php56w-soap-5.6.2-1.w7.x86_64 --> Running transaction check ---> Package php56w-common.x86_64 0:5.6.2-1.w7 will be installed Removing php56w-common.x86_64 0:5.6.2-1.w7 - u due to obsoletes from installed php-common-5.6.4-2.el7.remi.x86_64 --> Restarting Dependency Resolution with new changes. --> Running transaction check ---> Package php56w-common.x86_64 0:5.6.2-1.w7 will be installed --> Processing Dependency: php56w-common(x86-64) = 5.6.2-1.w7 for package: php56w-soap-5.6.2-1.w7.x86_64 --> Finished Dependency Resolution Error: Package: php56w-soap-5.6.2-1.w7.x86_64 (webtatic) Requires: php56w-common(x86-64) = 5.6.2-1.w7 Available: php56w-common-5.6.0-1.w7.x86_64 (webtatic) php56w-common(x86-64) = 5.6.0-1.w7 Available: php56w-common-5.6.0-2.w7.x86_64 (webtatic) php56w-common(x86-64) = 5.6.0-2.w7 Available: php56w-common-5.6.1-1.w7.x86_64 (webtatic) php56w-common(x86-64) = 5.6.1-1.w7 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest
I have tried with both the
--skip-broken and the
rpm -Va --nofiles --nodigest workarounds and both to no avail.
Is there anything else that I can do to get this off the ground?
My currently installed version of PHP was 5.4.10 then it got downgraded to 5.4.6. I cannot go lower than 5.4.6 for compliance purposes, but I now do need PHP-SOAP to be installed.
Is there something I’m possibly overlooking or missing?
You seem to be confused as to what version of PHP is installed on your system now, so let’s start there.
First, you have PHP 5.6.4 installed, from the remi-php56 repository, not PHP 5.4.6. You should have no issues installing
php-soap from remi-php56, presuming you remembered to enable the remi and remi-php56 repos. Since they appear to be disabled, that is almost certainly the cause of the problem.
There’s no need to add webtatic here, and the cause of this error is that the webtatic packages conflict with the remi packages. You should remove the webtatic repo, enable the remi and remi-php56 repos, and then install php-soap.
(Remi’s high quality packages over the years helped him become an official Fedora packager and become employed at Red Hat. I don’t know who the webtatic people are, but I have never been impressed by the quality of their packages.)
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.