puppet enterprise installation error

Olive asked:

I am using puppet-enterprise-3.3.2-el-6-x86_64.tar.gz to install puppet enterprise, after installation I got

ERROR: Could not install required packages--this may be due to a network failure or incorrect repository
  settings. You must install the following packages before you can install Puppet Enterprise:
 pe-puppet-server and pe-rubycas-server

while I install I got

pe-httpd.worker is stopped. 

Also I tried “service pe-httpd status” it shows

pe-httpd.worker is stopped.

I suspect due to this I got n/w failure error

I have done below validation
1) yum.log – No error message
2) install_log.lastrun.$HOSTNAME – No error message. I have seen complete message.
3) puppet –version – shows 3.7.2 (Puppet Enterprise 3.7.0)
4) also I ran puppet apply -e ‘notify { “Hello, world!”: }’ – it worked with out any error

I tried to install pe-puppet-server(just for my referrence)

yum install pe-puppet-server

got below message

Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or Red Hat Satellite.
Setting up Install Process
Package pe-puppet-server-3.6.2.14-1.pe.el6.noarch is obsoleted by pe-puppetserver-common-3.7.2.2-1.pe.el6.noarch which is already installed
Nothing to do

but in package folder I could not find pe-puppetserver-common-3.7.2.2-1.pe.el6.noarch.
Not sure how it get inatalled.

Also I grep “rmp -qa|grep pe-puppetserver-common-3.7.2.2-1.pe.el6.noarch” it shows pe-puppetserver-common-3.7.2.2-1.pe.el6.noarch.
I unstalled PE and done yum clean all. Again tried to re-install PE. Again getting same error.

The network failure or incorrect repository error is common.If not, please help me to resolve.

Also I try to install3.3.2 but why it shows 3.7 PE version please correct me if my understaning is wrong.

My answer:


You already installed Puppet Enterprise 3.7 on this computer. You cannot downgrade to 3.3 using the installer.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.