YUM Update Error

Ryan Prentiss asked:

I am receiving the following errors when running yum update. I began receiving these errors after I had installed the incorrect EPEL package (epel-release-6-8.noarch). I have since removed and installed epel-release-7-5.noarch instead.

Can anyone help me to resolve this issue?

Running CentOS 7

[xxxxxx]# yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.mirror.nac.net
 * epel: mirror.cogentco.com
 * extras: mirror.us.leaseweb.net
 * updates: mirror.sanctuaryhost.com
Resolving Dependencies
--> Running transaction check
---> Package jansson.x86_64 0:2.4-6.el7 will be updated
---> Package jansson.x86_64 0:2.6-1.el6 will be an update
---> Package python-boto.noarch 0:2.25.0-2.el7.centos will be updated
---> Package python-boto.noarch 0:2.34.0-4.el6 will be an update
--> Processing Dependency: python(abi) = 2.6 for package: python-boto-2.34.0-4.el6.noarch
--> Processing Dependency: python-rsa for package: python-boto-2.34.0-4.el6.noarch
---> Package python-jsonpointer.noarch 0:1.0-2.el7.centos will be updated
---> Package python-jsonpointer.noarch 0:1.0-3.el6 will be an update
--> Processing Dependency: python(abi) = 2.6 for package: python-jsonpointer-1.0-3.el6.noarch
---> Package python-six.noarch 0:1.3.0-4.el7 will be updated
---> Package python-six.noarch 0:1.7.3-1.el6 will be an update
--> Processing Dependency: python(abi) = 2.6 for package: python-six-1.7.3-1.el6.noarch
---> Package qrencode-libs.x86_64 0:3.4.1-3.el7 will be updated
---> Package qrencode-libs.x86_64 0:3.4.2-1.el6 will be an update
--> Running transaction check
---> Package python-boto.noarch 0:2.34.0-4.el6 will be an update
--> Processing Dependency: python(abi) = 2.6 for package: python-boto-2.34.0-4.el6.noarch
---> Package python-jsonpointer.noarch 0:1.0-3.el6 will be an update
--> Processing Dependency: python(abi) = 2.6 for package: python-jsonpointer-1.0-3.el6.noarch
---> Package python-rsa.noarch 0:3.1.1-5.el6 will be installed
--> Processing Dependency: python(abi) = 2.6 for package: python-rsa-3.1.1-5.el6.noarch
---> Package python-six.noarch 0:1.7.3-1.el6 will be an update
--> Processing Dependency: python(abi) = 2.6 for package: python-six-1.7.3-1.el6.noarch
--> Finished Dependency Resolution
Error: Package: python-boto-2.34.0-4.el6.noarch (epel)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-16.el7.x86_64 (@anaconda)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: python-six-1.7.3-1.el6.noarch (epel)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-16.el7.x86_64 (@anaconda)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: python-jsonpointer-1.0-3.el6.noarch (epel)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-16.el7.x86_64 (@anaconda)
               python(abi) = 2.7
               python(abi) = 2.7
Error: Package: python-rsa-3.1.1-5.el6.noarch (epel)
           Requires: python(abi) = 2.6
           Installed: python-2.7.5-16.el7.x86_64 (@anaconda)
               python(abi) = 2.7
               python(abi) = 2.7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

My answer:


You need to:

  1. Clear your yum cache.

    yum clean all
    
  2. Resync your installed packages with what’s in the repos.

    yum distro-sync
    

View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.