Trying to install php-mcrypt

user3446561 asked:

[root@localhost ~]# yum install php-mcrypt
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: mirror.as43289.net
 * epel: ftp.colocall.net
 * extras: mirror.as43289.net
 * updates: mirror.as43289.net
Resolving Dependencies
--> Running transaction check
---> Package php-mcrypt.i686 0:5.3.3-3.el6 will be installed
--> Processing Dependency: php(zend-abi) = 20090626 for package: php-mcrypt-5.3.3-3.el6.i686
--> Processing Dependency: php(api) = 20090626 for package: php-mcrypt-5.3.3-3.el6.i686
--> Processing Dependency: libmcrypt.so.4 for package: php-mcrypt-5.3.3-3.el6.i686
--> Running transaction check
---> Package libmcrypt.i686 0:2.5.8-9.el6 will be installed
---> Package php-mcrypt.i686 0:5.3.3-3.el6 will be installed
--> Processing Dependency: php(zend-abi) = 20090626 for package: php-mcrypt-5.3.3-3.el6.i686
--> Processing Dependency: php(api) = 20090626 for package: php-mcrypt-5.3.3-3.el6.i686
--> Finished Dependency Resolution
Error: Package: php-mcrypt-5.3.3-3.el6.i686 (epel)
           Requires: php(zend-abi) = 20090626
           Installed: php-common-5.4.38-1.el6.remi.i686 (@remi)
               php(zend-abi) = 20100525-x86-32
           Available: php-common-5.3.3-38.el6.i686 (base)
               php(zend-abi) = 20090626
           Available: php-common-5.3.3-40.el6_6.i686 (updates)
               php(zend-abi) = 20090626
Error: Package: php-mcrypt-5.3.3-3.el6.i686 (epel)
           Requires: php(api) = 20090626
           Installed: php-common-5.4.38-1.el6.remi.i686 (@remi)
               php(api) = 20100412-x86-32
           Available: php-common-5.3.3-38.el6.i686 (base)
               php(api) = 20090626
           Available: php-common-5.3.3-40.el6_6.i686 (updates)
               php(api) = 20090626
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Do i have to install everything from the start, or is there a way around this? Thank you in advance.

resolved:
https://www.conetix.com.au/blog/australian-remi-repository

My answer:


You installed PHP from the remi repository, but you disabled the repository. So yum can’t install additional packages from it.

To resolve the problem, re-enable the remi repository.

yum-config-manager --enable remi

View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.