Postfix fails to install in MySQL 5.7

user1179459 asked:

I am trying to install postfix in my server with

Centos7
MySQL 5.7

Unfortunately it seems to be they are incompatible. Why?

Here the error message. Is there a way around this ?

[root@doc ~]# yum --enablerepo=remi install postfix
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.sonn.com
 * epel: mirror.nus.edu.sg
 * extras: centos.sonn.com
 * remi: mirrors.thzhost.com
 * updates: centos.sonn.com
Resolving Dependencies
--> Running transaction check
---> Package postfix.x86_64 2:2.10.1-6.el7 will be installed
--> Processing Dependency: libmysqlclient.so.18(libmysqlclient_18)(64bit) for package: 2:postfix-2.10.1-6.el7.x86_64
--> Processing Dependency: libmysqlclient.so.18()(64bit) for package: 2:postfix-2.10.1-6.el7.x86_64
--> Running transaction check
---> Package MariaDB-shared.x86_64 0:10.0.17-1.el7.centos will be installed
--> Processing Dependency: MariaDB-common for package: MariaDB-shared-10.0.17-1.el7.centos.x86_64
--> Running transaction check
---> Package MariaDB-common.x86_64 0:10.0.17-1.el7.centos will be installed
--> Finished Dependency Resolution

Dependencies Resolved

=====================================================================================================================================================================================================
 Package                                          Arch                                     Version                                                   Repository                                 Size
=====================================================================================================================================================================================================
Installing:
 postfix                                          x86_64                                   2:2.10.1-6.el7                                            base                                      2.4 M
Installing for dependencies:
 MariaDB-common                                   x86_64                                   10.0.17-1.el7.centos                                      mariadb                                    23 k
 MariaDB-shared                                   x86_64                                   10.0.17-1.el7.centos                                      mariadb                                   1.2 M

Transaction Summary
=====================================================================================================================================================================================================
Install  1 Package (+2 Dependent packages)

Total size: 3.7 M
Installed size: 13 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test


Transaction check error:
  file /usr/share/mysql/charsets/Index.xml from install of MariaDB-common-10.0.17-1.el7.centos.x86_64 conflicts with file from package mysql-community-common-5.7.6-0.3.m16.el6.x86_64
  file /usr/share/mysql/charsets/armscii8.xml from install of MariaDB-common-10.0.17-1.el7.centos.x86_64 conflicts with file from package mysql-community-common-5.7.6-0.3.m16.el6.x86_64
  file /usr/share/mysql/charsets/ascii.xml from install of MariaDB-common-10.0.17-1.el7.centos.x86_64 conflicts with file from package mysql-community-common-5.7.6-0.3.m16.el6.x86_64
  file /usr/share/mysql/charsets/cp1250.xml from install of MariaDB-common-10.0.17-1.el7.centos.x86_64 conflicts with file from package mysql-community-common-5.7.6-0.3.m16.el6.x86_64
  file /usr/share/mysql/charsets/cp1256.xml from install of MariaDB-common-10.0.17-1.el7.centos.x86_64 conflicts with file from package mysql-community-common-5.7.6-0.3.m16.el6.x86_64
  file /usr/share/mysql/charsets/cp1257.xml from install of MariaDB-common-10.0.17-1.el7.centos.x86_64 conflicts with file from package mysql-community-common-5.7.6-0.3.m16.el6.x86_64
  file /usr/share/mysql/charsets/cp850.xml from install of MariaDB-common-10.0.17-1.el7.centos.x86_64 conflicts with file from package mysql-community-common-5.7.6-0.3.m16.el6.x86_64
  file /usr/share/mysql/charsets/cp852.xml from install of MariaDB-common-10.0.17-1.el7.centos.x86_64 conflicts with file from package mysql-community-common-5.7.6-0.3.m16.el6.x86_64
  file /usr/share/mysql/charsets/cp866.xml from install of MariaDB-common-10.0.17-1.el7.centos.x86_64 conflicts with file from package mysql-community-common-5.7.6-0.3.m16.el6.x86_64
  file /usr/share/mysql/charsets/dec8.xml from install of MariaDB-common-10.0.17-1.el7.centos.x86_64 conflicts with file from package mysql-community-common-5.7.6-0.3.m16.el6.x86_64
  file /usr/share/mysql/charsets/geostd8.xml from install of MariaDB-common-10.0.17-1.el7.centos.x86_64 conflicts with file from package mysql-community-common-5.7.6-0.3.m16.el6.x86_64
  file /usr/share/mysql/charsets/greek.xml from install of MariaDB-common-10.0.17-1.el7.centos.x86_64 conflicts with file from package mysql-community-common-5.7.6-0.3.m16.el6.x86_64
  file /usr/share/mysql/charsets/hebrew.xml from install of MariaDB-common-10.0.17-1.el7.centos.x86_64 conflicts with file from package mysql-community-common-5.7.6-0.3.m16.el6.x86_64
  file /usr/share/mysql/charsets/hp8.xml from install of MariaDB-common-10.0.17-1.el7.centos.x86_64 conflicts with file from package mysql-community-common-5.7.6-0.3.m16.el6.x86_64
  file /usr/share/mysql/charsets/keybcs2.xml from install of MariaDB-common-10.0.17-1.el7.centos.x86_64 conflicts with file from package mysql-community-common-5.7.6-0.3.m16.el6.x86_64
  file /usr/share/mysql/charsets/koi8r.xml from install of MariaDB-common-10.0.17-1.el7.centos.x86_64 conflicts with file from package mysql-community-common-5.7.6-0.3.m16.el6.x86_64
  file /usr/share/mysql/charsets/koi8u.xml from install of MariaDB-common-10.0.17-1.el7.centos.x86_64 conflicts with file from package mysql-community-common-5.7.6-0.3.m16.el6.x86_64
  file /usr/share/mysql/charsets/latin1.xml from install of MariaDB-common-10.0.17-1.el7.centos.x86_64 conflicts with file from package mysql-community-common-5.7.6-0.3.m16.el6.x86_64
  file /usr/share/mysql/charsets/latin2.xml from install of MariaDB-common-10.0.17-1.el7.centos.x86_64 conflicts with file from package mysql-community-common-5.7.6-0.3.m16.el6.x86_64
  file /usr/share/mysql/charsets/latin5.xml from install of MariaDB-common-10.0.17-1.el7.centos.x86_64 conflicts with file from package mysql-community-common-5.7.6-0.3.m16.el6.x86_64
  file /usr/share/mysql/charsets/latin7.xml from install of MariaDB-common-10.0.17-1.el7.centos.x86_64 conflicts with file from package mysql-community-common-5.7.6-0.3.m16.el6.x86_64
  file /usr/share/mysql/charsets/macce.xml from install of MariaDB-common-10.0.17-1.el7.centos.x86_64 conflicts with file from package mysql-community-common-5.7.6-0.3.m16.el6.x86_64
  file /usr/share/mysql/charsets/macroman.xml from install of MariaDB-common-10.0.17-1.el7.centos.x86_64 conflicts with file from package mysql-community-common-5.7.6-0.3.m16.el6.x86_64
  file /usr/share/mysql/charsets/swe7.xml from install of MariaDB-common-10.0.17-1.el7.centos.x86_64 conflicts with file from package mysql-community-common-5.7.6-0.3.m16.el6.x86_64
  file /etc/my.cnf from install of MariaDB-common-10.0.17-1.el7.centos.x86_64 conflicts with file from package mysql-community-server-5.7.6-0.3.m16.el6.x86_64

Error Summary
-------------

My answer:


You have configured your system with repositories for both MySQL 5.7 and MariaDB 10.0. This is not going to work; these packages cannot be run side-by-side on the same system. You will need to choose one or the other.

Obviously since CentOS is already expecting to use MariaDB and for various other reasons, you should probably choose MariaDB rather than MySQL.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.