Error installing php-devel 5.5 CentOS 6

Carter asked:

I am trying to run pecl install couchbase but am having trouble with php-devel and its dependencies.

When I try to run yum --enablerepo=remi-php55 install php-devel I get the following error. My current version of php is 5.5.16. It looks like I need to update the gd lib but when I run yum check-update I do not see the gd lib in the list.

Error message:

Error: Package: php-gd-5.5.25-1.el6.remi.x86_64 (remi-php55)
       Requires: gd-last(x86-64) >= 2.1.1
       Installed: gd-last-2.1.0-3.el6.remi.x86_64 (@remi)
           gd-last(x86-64) = 2.1.0-3.el6.remi

My answer:


The package gd-last is in the remi repository, but you disabled it. You need to enable the repository to install packages from it.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.