Error: Package: libmodule-10.0.0.1826-b10_0_0_1826.x86_64 (installed)

the-a-train asked:

I am getting the following messages when running yum update on my RHEL 6 server. I have tried searching on the libmodule-10.0.0.1826-b10_0_0_1826.x86_64 package and dependencies but can’t find a solution.

Loaded plugins: product-id, rhnplugin, security, subscription-manager
This system is receiving updates from RHN Classic or RHN Satellite.
Setting up Update Process
rhel-x86_64-server-6                                     | 1.8 kB     00:00
Resolving Dependencies
--> Running transaction check
---> Package unixODBC.x86_64 0:2.2.11-7.1 will be updated
--> Processing Dependency: libodbc.so.1()(64bit) for package: libmodule-10.0.0.1826-b10_0_0_1826.x86_64
---> Package unixODBC.x86_64 0:2.2.14-14.el6 will be an update
--> Processing Dependency: libltdl.so.7()(64bit) for package: unixODBC-2.2.14-14.el6.x86_64
--> Running transaction check
---> Package libtool-ltdl.x86_64 0:2.2.6-15.5.el6 will be installed
---> Package unixODBC.x86_64 0:2.2.11-7.1 will be updated
--> Processing Dependency: libodbc.so.1()(64bit) for package: libmodule-10.0.0.1826-b10_0_0_1826.x86_64
--> Finished Dependency Resolution
Error: Package: libmodule-10.0.0.1826-b10_0_0_1826.x86_64 (installed)
           Requires: libodbc.so.1()(64bit)
           Removing: unixODBC-2.2.11-7.1.x86_64 (installed)
               libodbc.so.1()(64bit)
           Updated By: unixODBC-2.2.14-14.el6.x86_64 (rhel-6-server-fastrack-rpms)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

My answer:


Your local copy of the repository metadata is out of sync with what the repositories contain.

Clear your metadata and try again.

yum clean metadata

or

yum clean all

View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.