Install SPDY failed

Victoria Whitehead asked:

I am trying to install SPDY on my server. I am running CENTOS 6.6 x86_64 with Apache.

I am using the following guide, https://www.howtoforge.com/using-mod_spdy-with-apache2-on-centos-6.3

But getting the following error when I try to install SPDY..

warning: mod-spdy-beta_current_x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 7fac5991: NOKEY
error: Failed dependencies:
httpd >= 2.2.4 is needed by mod-spdy-beta-0.9.4.3-420.x86_64
mod_ssl >= 2.2 is needed by mod-spdy-beta-0.9.4.3-420.x86_64

I have the latest version of mod_ssl installed and a later version of Apache. Any suggestions on how to resolve this?
THanks

My answer:


That guide has an error, and you stumbled right into it:

rpm -U mod-spdy-*.rpm

This is wrong, and results in the error message that you see. This is because rpm does not resolve dependencies on its own, and your system doesn’t yet have the necessary dependencies installed.

The correct way to install locally downloaded packages while resolving dependencies is:

yum install mod-spdy*.rpm

This can also happen if you skipped the “installing Apache” section, and installed it yourself from a source other than the base repositories. You can’t use that guide in this case; you will need to build mod_spdy against your custom Apache installation yourself.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.