Can't install PHP 5.5 on CentOS 6.7

Alberto Fontana asked:

I have a dedicated server on Kimsufi.
I am trying to update PHP 5.3 to PHP 5.5 on CentOS 6.7 using this guide, but unfortunately i get the following errors:

Error: Package: php-mysql-5.4.45-1.el6.remi.x86_64 (remi)
       Requires: php-pdo(x86-64) = 5.4.45-1.el6.remi
       Removing: php-pdo-5.3.3-27.el6.2.x86_64 (@LocalRepo)
           php-pdo(x86-64) = 5.3.3-27.el6.2
       Updated By: php-pdo-5.5.29-1.el6.remi.x86_64 (remi-php55)
           php-pdo(x86-64) = 5.5.29-1.el6.remi
       Available: php-pdo-5.4.44-1.el6.remi.x86_64 (remi)
           php-pdo(x86-64) = 5.4.44-1.el6.remi
       Available: php-pdo-5.4.45-1.el6.remi.x86_64 (remi)
           php-pdo(x86-64) = 5.4.45-1.el6.remi
       Available: php-pdo-5.5.28-1.el6.remi.x86_64 (remi-php55)
           php-pdo(x86-64) = 5.5.28-1.el6.remi
       Available: php54w-pdo-5.4.44-1.w6.x86_64 (webtatic)
           php-pdo(x86-64) = 5.4.44-1.w6
       Available: php55w-pdo-5.5.28-1.w6.x86_64 (webtatic)
           php-pdo(x86-64) = 5.5.28-1.w6
       Available: php56w-pdo-5.6.12-1.w6.x86_64 (webtatic)
           php-pdo(x86-64) = 5.6.12-1.w6
Error: Package: php-pecl-apc-3.1.9-2.el6.x86_64 (@base)
           Requires: php(api) = 20090626
           Removing: php-common-5.3.3-27.el6.2.x86_64 (@LocalRepo)
               php(api) = 20090626
           Updated By: php-common-5.5.29-1.el6.remi.x86_64 (remi-php55)
               php(api) = 20121113-64
           Available: php-common-5.4.44-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.4.45-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.5.28-1.el6.remi.x86_64 (remi-php55)
               php(api) = 20121113-64
           Available: php54w-common-5.4.44-1.w6.x86_64 (webtatic)
               php(api) = 20100412-64
           Available: php55w-common-5.5.28-1.w6.x86_64 (webtatic)
               php(api) = 20121113-64
           Installing: php56w-common-5.6.12-1.w6.x86_64 (webtatic)
               php(api) = 20131106-64
Error: Package: php-pecl-apc-3.1.9-2.el6.x86_64 (@base)
           Requires: php(zend-abi) = 20090626
           Removing: php-common-5.3.3-27.el6.2.x86_64 (@LocalRepo)
               php(zend-abi) = 20090626
           Updated By: php-common-5.5.29-1.el6.remi.x86_64 (remi-php55)
               php(zend-abi) = 20121212-64
           Available: php-common-5.4.44-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.4.45-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.5.28-1.el6.remi.x86_64 (remi-php55)
               php(zend-abi) = 20121212-64
           Available: php54w-common-5.4.44-1.w6.x86_64 (webtatic)
               php(zend-abi) = 20100525-64
           Available: php55w-common-5.5.28-1.w6.x86_64 (webtatic)
               php(zend-abi) = 20121212-64
           Installing: php56w-common-5.6.12-1.w6.x86_64 (webtatic)
               php(zend-abi) = 20131226-64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

What do they mean exactly and how can i fix them?

My answer:


You have a conflicting repository named webtatic installed. Remove this repo (and any packages installed from it).

Once this is done, run yum distro-sync to sync your system to the latest versions of packages which are in the repositories.

At this point, you can install any additional packages you need.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.