CentOS dependency yum

lcssanches asked:

Well, this is like hell for me. For the second time. Last time I give up and install apache+php on Windows. Now I decide to ask.

A hour ago I install php54w in CentOS 6.7. To do that I add the following repo:

rpm -Uvh http://repo.webtatic.com/yum/el6/latest.rpm

But I needed to install mbstring and I get a conflict error. So I uninstall php54w I tried to install php (yum install php, 5.3.3). Again I get conflicts.

Then I remove (at least i think I do that) the repo

yum remove webtatic-release

Well, now it’ll work! Yes? No! =/

dependency error

How can I resolve this?

My answer:


You got that error because your system still has the package php54w-common installed. After you remove this, you can continue.

As for webtatic, I would never recommend that. I always recommend you use the remi repository. He also builds the official Red Hat packages, and provides repos with newer versions of PHP for those who need them.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.