Can Nginx 1.8.0 use SSL when installed from PPA?

weeksling asked:

I’ve seen plenty of resources in the indicate that when installing Nginx, you absolutely MUST compile from source using the –with-http_ssl_module option in order to use ssl.
However, all of these resource seem to be referencing versions of Nginx of versions 0.x.x

I have also personally used ssl directive in the past on an Nginx server installed from the Nginx PPA, and the service runs without any error messages. Is this secure, or is there some facet of ssl that it is missing that I’m not understanding?

My answer:


The version of nginx you got from the PPA is compiled with --with-http_ssl_module.

You can see this by inspecting the output from nginx -V.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.