Conflicts in files when installing libxml2

Garg asked:

Very new in Linux/Unix so please advice me something for the problem here. I have trying to install libxml2-devel from RPM but I got this message

rpm -ivh libxml2-devel-2.9.1-5.el7_0.1.x86_64.rpm 
error: Failed dependencies:
libxml2 = 2.9.1-5.el7_0.1 is needed by libxml2-devel-2.9.1-5.el7_0.1.x86_64

So then I tried to install libxml2 and got this:

# rpm -ivh libxml2-2.9.1-5.el7_0.1.x86_64.rpm 
warning: libxml2-2.9.1-5.el7_0.1.x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 192a7d7d: NOKEY
Preparing...                          ################################# [100%]
file /usr/bin/xmlcatalog from install of libxml2-2.9.1-5.el7_0.1.x86_64 conflicts with file from package libxml2-2.9.1-5.el7.x86_64
file /usr/bin/xmllint from install of libxml2-2.9.1-5.el7_0.1.x86_64 conflicts with file from package libxml2-2.9.1-5.el7.x86_64
file /usr/lib64/libxml2.so.2.9.1 from install of libxml2-2.9.1-5.el7_0.1.x86_64 conflicts with file from package libxml2-2.9.1-5.el7.x86_64

Note that there is no Internet access on the machine and installation is offline that’s why I using RPMs.

The system is running on CentOS 7.

Please advice me if I can do something here?

My answer:


You already have an older version of libxml2 installed, so you need to update it first.

rpm -Uvh libxml2-*

View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.