Drupal 8.0.5 and FreeBSD 10.2 Issues

Pythonicator asked:

I am running a FreeBSD 10.2 server with Apache 2.4.18, php56-, and SQL 57. I am trying to install Drupal 8.0.5, but I am stuck. I got the PHP stuff working, as well as the clean URL things that drupal requires. But I have hit a snag in that I can’t get access to the SQL database option (the only one available is SQLLite, which is not what I want). Back when I was running Drupal on my Linux box, it used to be that the installer saw SQL and would allow me to set it up that way. But this is not the case now. Do I need to install another extension to get things working, or edit settings.php by hand?

My answer:


You seem to be missing php56-pdo and php56-pdo_mysql. Go pkg install those and try again.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.