Unable to install Subversion on Centos 6

Nicholas Law asked:

I am attempting to install the subversion client on Centos 6.7 but after running:

yum install subversion

I get the below response:

Error: Package: subversion-1.6.17-1.el5.x86_64 (amberdms-updates)
Requires: libneon.so.25()(64bit)
Error: Package: subversion-1.6.17-1.el5.x86_64 (amberdms-updates)
Requires: python(abi) = 2.4
Installed: python-2.6.6-64.el6.x86_64 (@base)
python(abi) = 2.6
Available: python26-2.6.5-6.el5.x86_64 (amberdms-os)
python(abi) = 2.6
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Do I need to manually install the above dependencies?

Or is there another way of installing subversion?

My answer:


You’re running CentOS 6, but you’ve installed third party repositories amberdms-updates and amberdms-os, possibly among others, which are designed for CentOS 5.

Remove them (and any other inappropriate repos) and replace them with the correct repositories.

After doing so, you will need to clean old metadata from your system and replace existing inappropriate packages with correct packages.

yum clean all
yum distro-sync

View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.