Upgrading curl on centos 6: libcurl-7.50 requires libnghttp2

keeg asked:

I am trying to upgrade curl but keep on getting this error:

Package: libcurl-7.50.0-1.1.cf.rhel6.x86_64 (CityFan)
Requires: libnghttp2.so.14()(64bit)

I am not sure how to get this required package? I’m using city-fan.org-release-1-13.rhel6.noarch repo

My answer:


You’re using the third party city-fan repository. This repo has dependencies which are in the EPEL repository, one of which is libnghttp2, so you must have EPEL enabled to use city-fan.


View the full question and answer on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.